全国免费电话:4008-233-667

微信客服
在线微信客服
Ctrl+D【收藏】

基于Packet Tracer的GRE隧道配置实验设计

2019-03-15 围观 : 评论 论文发表
论文发表服务
论文撰写+发表 Tel:
客服QQ: 微信:

高彬

摘要:鉴于计算机网络硬件实验平台的局限性,应用虚拟仿真软件进行实验教学是必要的。简要介绍了Packet Tracer网络仿真软件并阐述了通用路由封装协议(Generic Routing Encapsulation,GRE)隧道技术原理,进而基于Packet Tracer仿真软件设计了GRE隧道配置实验方案,包括实验目的、网络拓扑结构设计、网络参数设置、实验环境配置,以及上述配置结果的验证方式等。教学实践表明:采用该实验方案进行教学有助于学生对网络知识的理解掌握和综合运用,可以作为传统网络实验教学的有效补充和扩展。

关键词:计算機网络;Packet Tracer仿真软件;通用路由封装协议;网络实验;实验设计

中图分类号:TP393.9 文献标识码:A 文章编号:1009-3044(2018)16-0030-04

Design of GRE Tunnel Configuration Experiment Based on Packet Tracer

GAO Bin

(Lab Center, College of Information Science and Engineering, Northeastern University, Shenyang 110819, China)

Abstract: Due to the limitation of hardware experimental platforms for computer network, it is necessary to apply virtual simulation software in experimental teaching. The Packet Tracer network simulation software and the theory of GRE tunnel technology are briefly introduced. An experimental scheme for GRE tunnel configuration based on Packet Tracer in presented, including purpose of the experiments, design of the network topology, configuration of network parameters and experimental environments, and validation of the configuration aforementioned. Teaching practices indicate that this experimental scheme is helpful for the students to understand and use the knowledge of network and that the proposed scheme is a valid expansion of the classical network experiments.

Key words: computer networks; Packet Tracer simulation software; generic routing encapsulation (GRE); network experiment; experimental design.

1 引言

计算机网络是一门强调应用、技术性很强的课程,实验是整个教学过程中的重要环节。传统计算机网络实验室采用硬件实物搭建,虽然满足了学生对网络设备的直观感性认识和操作体验,但由于投资大、维护成本高,实验室建设规模普遍不足,而且硬件环境使用受时间和空间限制,难以在教学周期内完全满足学生的实验需要。目前存在很多款功能强大的虚拟仿真软件,如Packet Tracer,在普通计算机上就可以运行,使用不受时空限制,完全可以作为计算机网络实验的有效补充和扩展。基于虚拟仿真软件设计实验方案,有助于激发学生学习兴趣,锻炼学生应用技能,提高对理论知识的学习、掌握和升华[1-4]。

2 Packet Tracer软件介绍

Cisco Packet Tracer 是由Cisco公司发布的一款学习用模拟软件。作为辅助学习工具为学习网络课程的初学者去设计、配置、排除网络故障提供了网络模拟环境。用户可以在软件的图形用户界面上直接使用拖曳方法建立网络拓扑,并可提供数据包在网络中行进的详细处理过程,观察网络实时运行情况[5-6]。本实验设计采用的版本是Packet Tracer 6.2。

3 GRE隧道技术原理

虚拟专用网络(Virtual Private Network,VPN)的功能是:在公用网络上建立专用网络,进行加密通讯。在企业网络中有广泛应用。VPN网关通过对数据包的加密和数据包目标地址的转换实现远程访问。隧道技术是实现虚拟专用网的方法之一。

隧道技术(Tunneling)是一种通过使用互联网+络的基础设施在网络之间传递数据的方式。使用隧道传递的数据(或负载)可以是不同协议的数据帧或包。隧道协议将其他协议的数据帧或包重新封装然后通过隧道发送。新的帧头提供路由信息,以便通过互联网传递被封装的负载数据。

通用路由封装协议(Generic Routing Encapsulation,GRE)是对某些网络层协议(如ip 和ipx)的数据包进行封装,使这些被封装的数据包能够在另一个网络层协议(如ip)中传输。最早是由Cisco和Net-smiths等公司提出,目前多数厂商的网络设备均支持GRE隧道协议。GRE 是VPN的第三层隧道协议,规定了如何用一种网络协议去封装另一种网络协议报文的方法,使报文能够在异种网络中实现点对点传输[7-9]。

4 GRE隧道配置实验设计

4.1 实验目的

通过GRE隧道配置实验理解隧道技术的工作原理,掌握GRE隧道的基本配置与实现过程。

4.2 网络拓扑结构设计

仿真环境选用1台2621XM路由器(命名为ISP)、2台2811路由器(命名为R1、R2)和2台PC-PT计算机(命名为PC1、PC2)组成,其网络拓扑结构如图1所示。

4.3 网络参数设计

仿真环境中各网络设备的网络参数如表1所示,子网掩码均为255.255.255.0。

4.4 配置实验实现

4.4.1 实验环境配置

在Packet Tracer仿真软件中,按照图1网络拓扑图搭建设备仿真环境,由于路由器2811与2621XM默认是没有串口的,需要添加对应组件,参照图2路由器添加串口模块示意图,按如下步骤操作:1)点击对应路由器,打开Physical标签页,关掉路由器电源;2)在左侧模块列表,点击WIC-2T ;3)选中右下角WIC-2T组件,拖动到电源按钮旁边的黑色接口窗口处;4)点击Config标签,左侧列表中可看到新增串口;5)重新打开电源。

4.4.2 网络参数配置

在仿真软件界面中单击需要进行配置的设备,在该设备的CLI窗口中进行配置。下面是配置过程,对于首次出现的命令进行了注释。

1)配置路由器R1网络参数

Router>enable //进入特权模式

Router#configure terminal//进入全局配置

Router(config)#hostname R1//路由器命名R1

R1(config)#interface serial 0/0/0//进入路由器S0/0/0端口

R1(config-if)#ip address 202.118.2.1 255.255.255.0//配置端口IP地址

R1(config-if)#clock rate 64000//设置DCE端口时钟频率

R1(config-if)#no shutdown //激活端口

R1(config-if)#exit//退出路由器接口模式

R1(config)#interface fastEthernet 0/0//进入路由器f0/0端口

R1(config-if)#ip address 192.168.1.1 255.255.255.0//配置端口IP地址

R1(config-if)#no shutdown//激活端口

R1(config-if)#exit//退出路由器接口模式

R1(config)#ip route 0.0.0.0 0.0.0.0 202.118.2.2//配置R1默认路由

2)配置路由器R2网络参数

Router>enable

Router#configure terminal

Router(config)#hostname R2

R2(config)#interface serial 0/0/0

R2(config-if)#ip address 202.118.1.1 255.255.255.0

R2 (config-if)#clock rate 64000

R2 (config-if)#no shutdown

R2 (config-if)#exit

R2 (config)#interface fastEthernet 0/0

R2(config-if)#ip address 192.168.2.1 255.255.255.0

R2 (config-if)#no shutdown

R2 (config-if)#exit

R2(config)#ip route 0.0.0.0 0.0.0.0 202.118.1.2

3)配置路由器ISP网络参数

Router>en

Router#conf t

Router(config)#hostname ISP

ISP(config)#interface serial 0/0

ISP(config-if)#ip address 202.118.2.2 255.255.255.0

ISP(config-if)#clock rate 64000

ISP(config-if)#no shutdown

ISP(config-if)#exit

ISP(config)#interface serial 0/1

ISP(config-if)#ip address 202.118.1.2 255.255.255.0

ISP(config-if)#clock rate 64000

ISP(config-if)#no shutdown

4) 测试可达/不可达性

R2路由器ping 202.118.2.1,结果显示可达,ping 192.168.1.1结果显示不可达。這是没有进行GRE隧道配置时的网络联通状态。

5) 在R1与R2之间,创建隧道R1

R1>en

R1#conf t

R1(config)#interface tunnel 0//创建tunnel接口,编号为0

R1(config-if)#ip address 192.168.3.1 255.255.255.0//设置隧道接口IP地址

R1(config-if)#tunnel source s 0/0/0

// tunnel源接口,路由器将此接口地址作为源地址重封装数据包

R1(config-if)#tunnel destination 202.118.1.1

// tunnel目的IP地址,路由器将此地址作为目的地址重封装数据包

R1(config-if)#no sh

R1(config-if)#exit

R1(config)#router rip //运行动态路由RIP

R1(config-router)#network 192.168.1.0

R1(config-router)#network 192.168.3.0

//宣告网段

6) 在R1与R2之间,创建隧道R2

R2>en

R2#conf t

R2 (config)#interface tunnel 0

R2(config-if)#ip address 192.168.3.2 255.255.255.0

R2 (config-if)#tunnel source s 0/0/0

R2 (config-if)#tunnel destination 202.118.2.1

R2 (config-if)#no sh

R2 (config-if)#exit

R2 (config)#router rip

R2 (config-router)#network 192.168.2.0

R2 (config-router)#network 192.168.3.0

4.5 验证结果

1)测试可达及不可达性

R2路由器ping 202.118.2.1,结果显示可达,ping 192.168.1.1结果显示也可达。说明GRE隧道配置成功。

2)观察网络实时运行

通过仿真软件观察数据包在网络中行进的详细处理过程,如图3 打开仿真软件Simulation模式,通过R1的CLI,在全局模式下ping 192.168.2.1,点击视图中信封,在弹出的窗口中,观察隧道技术对IP的封装。

网络连通后,观察信封在路由器R1起始位置的信息,通过图4 R1路由器PDU(Protocol Data Unit,协议数据单元)信息OSI(Open System Interconnect Reference Model,开放式系统互联参考模型) 模型部分可以观察到在三层源和目的地址以及说明在tunnel0收到的数据包需要GRE封装。通过图5和图6可以观察到192网段源和目的地址通过GRE被封装成202网段源和目的地址。通过这个过程了解GRP隧道协议。

5 结束语

GRE隧道技术是计算机网络课程重要的知识点。通过Packet Tracer仿真软件进行GRE隧道配置实验,学生可以实际配置网络模拟环境、排除网络故障、观察网络实际运行情况,有助于理解掌握和综合运用网络知识。同时采用仿真软件辅助实验教学也弥补了硬件实验环境的不足,增加了计算机网络实验教学手段,提高了计算机网络实验教学水平。

参考文献

[1]肖明,石泽顺.计算机网络实验课程的探索与改革[J].计算机教育,2016(4):103-106.

[2]边胜琴,王建萍,崔晓龙.计算机网络实验室建设与实验教学改革[J].实验室研究与探索,2017,36(2):259-262.

[3]琚生根,陈黎,周刚,等.“计算机网络”实验课程的教学探讨[J].实验技术与管理,2013,30(4):159-161,165.

[4]钱权,张瑞,袁方.计算机网络课程中的项目式实验教学[J].实验室研究与探索,2013,32(5):142-145.

[5]张鹤飞,云红艳,张德祥,等. 基于Packet Tracer的校园网设计与仿真[J].实验室研究与探索,2017,36(10):127-130,157.

[6]杨殊,罗佳. 基于Packet Tracer软件的小型局域网络设计与仿真[J].实验技术与管理,2015,32(1):150-152.

[7]王丽娜,刘炎,何军. 基于IPSec和GRE的VPN实验仿真[J].实验室研究与探索,2013,32(9):70-75.

[8]焦慧华,李湘一,肖群. 基于Packet Tracer实验GRE VPN[J].安徽電子信息职业技术学院学报,2016,15(1):1-4.

[9]唐灯平. 基于Packet Tracer的GRE隧道配置实验教学设计[J].实验室研究与探索,2010,29(11):378-381.

《基于Packet Tracer的GRE隧道配置实验设计》转载自《电脑知识与技术》学术期刊,2018年16期 ,作者:高彬。

论文发表服务
论文撰写+发表 Tel:
客服QQ: 微信:

相关文章

留言与评论(共有 0 条评论)
   
验证码:
论文发表服务
论文发表服务